[РЕШЕНО] Не могу поставить Firefox

В этой теме задаем любые интересующие вопросы про Linux
Ответить
Серый
Сообщения: 844
Зарегистрирован: 27 сен 2012, 19:20
Темы: 102
Статус: Не в сети

[РЕШЕНО] Не могу поставить Firefox

Сообщение Серый » 20 янв 2013, 03:56

Собственно сабж. Проблема вроде как в adobe-flashplugin.

Код: Выделить всё

seryi@seryi-laptop:~$ ru sudo apt-get install firefox
[sudo] password for seryi: 
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Будут установлены следующие дополнительные пакеты:
  xul-ext-ubufox
Предлагаемые пакеты:
  firefox-gnome-support kmozillahelper
Пакеты, которые будут УДАЛЕНЫ:
  adobe-flashplugin
НОВЫЕ пакеты, которые будут установлены:
  firefox xul-ext-ubufox
обновлено 0, установлено 2 новых пакетов, для удаления отмечено 1 пакетов, и 176 пакетов не обновлено.
Необходимо скачать 0B/21,8MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 42,3MB.
Хотите продолжить [Д/н]? y
(Чтение базы данных ... на данный момент установлено 127427 файлов и каталогов.)
Удаляется пакет adobe-flashplugin ...
update-alternatives: error: нет альтернатив для iceape-flashplugin.
update-alternatives: error: нет альтернатив для iceape-flashplugin.
dpkg: не удалось обработать параметр adobe-flashplugin (--remove):
 подпроцесс установлен сценарий pre-removal возвратил код ошибки 2
postinst called with argument `abort-remove'
dpkg: ошибка при очистке -
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 adobe-flashplugin
E: Sub-process /usr/bin/dpkg returned an error code (1)
seryi@seryi-laptop:~$

Аватара пользователя
Porthos
Сообщения: 92
Зарегистрирован: 04 окт 2012, 23:19
Темы: 1
Откуда: EU
Статус: Не в сети

Re: Не могу поставить Firefox

Сообщение Porthos » 20 янв 2013, 11:14

Попробуй предварительно поставить пакет flashplugin-nonfree.
Кошки живут по обе стороны реальности.
(с) Constantine

Серый
Сообщения: 844
Зарегистрирован: 27 сен 2012, 19:20
Темы: 102
Статус: Не в сети

Re: Не могу поставить Firefox

Сообщение Серый » 20 янв 2013, 11:32

Поставил, не помогло.
СпойлерПоказать

Код: Выделить всё

seryi@seryi-laptop:~$ ru sudo apt-get install flashplugin-nonfree
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Будут установлены следующие дополнительные пакеты:
  flashplugin-installer libasound2-plugins libspeexdsp1
Предлагаемые пакеты:
  firefox firefox-3.0 konqueror-nsplugins ttf-xfree86-nonfree xfs
НОВЫЕ пакеты, которые будут установлены:
  flashplugin-installer flashplugin-nonfree libasound2-plugins libspeexdsp1
обновлено 0, установлено 4 новых пакетов, для удаления отмечено 0 пакетов, и 176 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 2 128B/181kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 680kB.
Хотите продолжить [Д/н]? y
Получено:1 http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse flashplugin-nonfree 11.2.202.261ubuntu0.10.04.1 [2 128B]
Получено 2 128Б за 0с (4 110Б/c)                
Предварительная настройка пакетов ...
Выбор ранее не выбранного пакета flashplugin-installer.
(Чтение базы данных ... на данный момент установлено 129061 файлов и каталогов.)
Распаковывается пакет flashplugin-installer (из файла .../flashplugin-installer_11.2.202.261ubuntu0.10.04.1_i386.deb)...
Выбор ранее не выбранного пакета flashplugin-nonfree.
Распаковывается пакет flashplugin-nonfree (из файла .../flashplugin-nonfree_11.2.202.261ubuntu0.10.04.1_i386.deb)...
Выбор ранее не выбранного пакета libspeexdsp1.
Распаковывается пакет libspeexdsp1 (из файла .../libspeexdsp1_1.2~rc1-1ubuntu1_i386.deb)...
Выбор ранее не выбранного пакета libasound2-plugins.
Распаковывается пакет libasound2-plugins (из файла .../libasound2-plugins_1.0.22-0ubuntu6_i386.deb)...
Настраивается пакет adobe-flashplugin (10.0.d32.18-1) ...
update-alternatives: используется `/usr/lib/adobe-flashplugin/libflashplayer.so' для предоставления `/usr/lib/iceape/plugins/flashplugin-alternative.so' (iceape-flashplugin) в автоматический режим.
update-alternatives: используется `/usr/lib/adobe-flashplugin/libflashplayer.so' для предоставления `/usr/lib/iceweasel/plugins/flashplugin-alternative.so' (iceweasel-flashplugin) в автоматический режим.
update-alternatives: используется `/usr/lib/adobe-flashplugin/libflashplayer.so' для предоставления `/usr/lib/mozilla/plugins/flashplugin-alternative.so' (mozilla-flashplugin) в автоматический режим.
update-alternatives: используется `/usr/lib/adobe-flashplugin/libflashplayer.so' для предоставления `/usr/lib/firefox/plugins/flashplugin-alternative.so' (firefox-flashplugin) в автоматический режим.
update-alternatives: используется `/usr/lib/adobe-flashplugin/libflashplayer.so' для предоставления `/usr/lib/xulrunner/plugins/flashplugin-alternative.so' (xulrunner-flashplugin) в автоматический режим.
update-alternatives: используется `/usr/lib/adobe-flashplugin/libflashplayer.so' для предоставления `/usr/lib/midbrowser/plugins/flashplugin-alternative.so' (midbrowser-flashplugin) в автоматический режим.
update-alternatives: используется `/usr/lib/adobe-flashplugin/libflashplayer.so' для предоставления `/usr/lib/xulrunner-addons/plugins/flashplugin-alternative.so' (xulrunner-addons-flashplugin) в автоматический режим.

Настраивается пакет flashplugin-installer (11.2.202.261ubuntu0.10.04.1) ...
Downloading...
--2013-01-20 11:27:49--  http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_11.2.202.261.orig.tar.gz
Преобразование адреса archive.canonical.com... 91.189.92.150, 91.189.92.191
Устанавливается соединение с archive.canonical.com|91.189.92.150|:80... соединились.
Запрос HTTP послан, ожидание ответа... 200 OK
Длина: 14131200 (13M) [application/x-gzip]
Saving to: «./adobe-flashplugin_11.2.202.261.orig.tar.gz»

     0K ........ ........ ........ ........ ........ ........ 22% 1,53M 7s
  3072K ........ ........ ........ ........ ........ ........ 44% 1,30M 5s
  6144K ........ ........ ........ ........ ........ ........ 66% 1,01M 4s
  9216K ........ ........ ........ ........ ........ ........ 89% 1,10M 1s
 12288K ........ ........ .......                            100% 1,22M=11s

2013-01-20 11:28:01 (1,21 MB/s) - «./adobe-flashplugin_11.2.202.261.orig.tar.gz» saved [14131200/14131200]

Download done.
Flash Plugin installed.

Настраивается пакет flashplugin-nonfree (11.2.202.261ubuntu0.10.04.1) ...
Настраивается пакет libspeexdsp1 (1.2~rc1-1ubuntu1) ...

Настраивается пакет libasound2-plugins (1.0.22-0ubuntu6) ...
Обрабатываются триггеры для libc-bin ...
ldconfig deferred processing now taking place
seryi@seryi-laptop:~$ ru sudo apt-get install firefox
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Будут установлены следующие дополнительные пакеты:
  xul-ext-ubufox
Предлагаемые пакеты:
  firefox-gnome-support kmozillahelper
Пакеты, которые будут УДАЛЕНЫ:
  adobe-flashplugin
НОВЫЕ пакеты, которые будут установлены:
  firefox xul-ext-ubufox
обновлено 0, установлено 2 новых пакетов, для удаления отмечено 1 пакетов, и 176 пакетов не обновлено.
Необходимо скачать 0B/21,8MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 42,3MB.
Хотите продолжить [Д/н]? y
(Чтение базы данных ... на данный момент установлено 129115 файлов и каталогов.)
Удаляется пакет adobe-flashplugin ...
update-alternatives: используется `/usr/lib/flashplugin-installer/libflashplayer.so' для предоставления `/usr/lib/mozilla/plugins/flashplugin-alternative.so' (mozilla-flashplugin) в автоматический режим.
update-alternatives: error: нет альтернатив для iceape-flashplugin.
update-alternatives: error: нет альтернатив для iceape-flashplugin.
dpkg: не удалось обработать параметр adobe-flashplugin (--remove):
 подпроцесс установлен сценарий pre-removal возвратил код ошибки 2
postinst called with argument `abort-remove'
dpkg: ошибка при очистке -
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 adobe-flashplugin
E: Sub-process /usr/bin/dpkg returned an error code (1)
seryi@seryi-laptop:~$

Аватара пользователя
Porthos
Сообщения: 92
Зарегистрирован: 04 окт 2012, 23:19
Темы: 1
Откуда: EU
Статус: Не в сети

Re: Не могу поставить Firefox

Сообщение Porthos » 20 янв 2013, 11:51

У тебя пакет adobe-flashplugin по-ходу битый. Удали под рутом все его файлы из всех директорий ручками, а напоследок упоминание о нём через Synaptic.
Кошки живут по обе стороны реальности.
(с) Constantine

Серый
Сообщения: 844
Зарегистрирован: 27 сен 2012, 19:20
Темы: 102
Статус: Не в сети

Re: Не могу поставить Firefox

Сообщение Серый » 20 янв 2013, 13:21

Porthos, спасибо, помогло.
Удалил файл /usr/lib/adobe-flashplugin.
Через synaptic не понял как делать, поэтому просто удалил упоминание о пакете adobe-flashplugin в файле /var/lib/dpkg/status.
После этого Firefox установился нормально.

Код: Выделить всё

sudo apt-get install firefox

Аватара пользователя
Porthos
Сообщения: 92
Зарегистрирован: 04 окт 2012, 23:19
Темы: 1
Откуда: EU
Статус: Не в сети

Re: Не могу поставить Firefox

Сообщение Porthos » 20 янв 2013, 13:30

Ю а велком, бро :)
З.Ы. В Synaptic просто найди adobe-flashplugin и ПКМ -> "Отметить для полного удаления".
Кошки живут по обе стороны реальности.
(с) Constantine

Серый
Сообщения: 844
Зарегистрирован: 27 сен 2012, 19:20
Темы: 102
Статус: Не в сети

Re: Не могу поставить Firefox

Сообщение Серый » 20 янв 2013, 13:37

Porthos писал(а):"Отметить для полного удаления"
Это я делал, но synaptic удалить не смог. Мне вообще почему-то synaptic не нравится, уж лучше все вручную править, так больше понимаешь что делаешь.

Аватара пользователя
Porthos
Сообщения: 92
Зарегистрирован: 04 окт 2012, 23:19
Темы: 1
Откуда: EU
Статус: Не в сети

Re: Не могу поставить Firefox

Сообщение Porthos » 20 янв 2013, 13:51

Synaptic всего лишь GUI для apt :)
Кошки живут по обе стороны реальности.
(с) Constantine

Аватара пользователя
ZEN
Администратор
Сообщения: 1330
Зарегистрирован: 27 сен 2012, 18:23
Темы: 204
Откуда: Украина, Одесса
Статус: Не в сети

Re: Не могу поставить Firefox

Сообщение ZEN » 20 янв 2013, 20:36

Менеджер пакетов не видит iceape-flashplugin. Серый, может лучше установить из http://mozilla.debian.net/ ?
бог создал труд и обезьяну
чтоб получился человек
а вот пингвина он не трогал
тот сразу вышел хорошо

Ответить

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей